BANCO MULTIPLE BHD, S. A incident with payment processing in Dominican Republic
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Dec 30, 2024 - 11:09 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Dec 30, 2024 - 09:29 GMT-03:00
This incident affected: CA Payments processing partners (Dominican Republic - Payment Processors).