Interswitch apparent incident with processing in Nigeria
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 11:34 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Jun 06, 2023 - 10:46 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Nigeria).