[ISW & Flutterwave -Recurring latency Issues] Apparent incident with payment processing in Nigeria

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Jun 07, 2026 - 10:13 GMT-03:00

Monitoring

The processor has stated that the incident with Zenith and GTBank have been recovering. We will keep you posted once the issue is fully resolved
Posted Jun 07, 2026 - 10:01 GMT-03:00

Update

We are still actively working on normalizing the latency on transactions. Feedback will be provided here as soon as we have an update
Posted Jun 07, 2026 - 04:59 GMT-03:00

Update

We have two major banks failing, Zenith and GT banks are current failing and have both been notified. We will share the update soon.
Posted Jun 07, 2026 - 01:49 GMT-03:00

Update

We continue to have this issue processor responded stating that the issue is still moving in and out of recovery rather than holding steady. We are aligned that latency is still visible and we are keeping pressure on this and will come back with the next material update.
Posted Jun 06, 2026 - 23:39 GMT-03:00

Investigating

We are currently investigating this issue.
Posted Jun 06, 2026 - 21:32 GMT-03:00
This incident affected: EMEA Payment processing partners (Nigeria - Payment Processors).