Nigeria -Opay Digital Services Limited- Latency Issue

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 16:58 GMT-03:00

Update

We are still experiencing this issue. We will update the processors feedback once available
Posted Mar 19, 2026 - 14:53 GMT-03:00

Update

We are still experiencing this issue. We will update the processors feedback once available.
Posted Mar 19, 2026 - 12:36 GMT-03:00

Update

The issue is still ongoing. We will update the processors comments once we receive them.
Posted Mar 19, 2026 - 10:09 GMT-03:00

Investigating

We have identified latency issues affecting payment processing with Opay Digital Services Limited in Nigeria. We have contacted the processor and are actively monitoring the situation. Updates will be provided as soon as additional information becomes available.
Posted Mar 19, 2026 - 03:00 GMT-03:00
This incident affected: EMEA Payment processing partners (Nigeria - Payment Processors).