[Izipay] Apparent incident with payment processing in Peru
Incident Report for Status dLocal
Resolved
This incident has been resolved, Interswitch Payments in Nigeria are operating correctly .
Posted Jun 02, 2023 - 07:51 GMT-03:00
Investigating
We have identified some processing issues with IZIPAY in PERU. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Jun 02, 2023 - 07:38 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Nigeria).