Iyzico- Apparent incident with payment processing in Turkey

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 09:34 GMT-03:00

Investigating

We have identified some processing issues with the processor Iyzico in Turkey. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Mar 24, 2025 - 09:05 GMT-03:00
This incident affected: EMEA Payment processing partners (Turkey - Payment Processors).