NEQUI services maintenance extended

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted May 27, 2026 - 19:41 GMT-03:00

Identified

Nequi has informed that the ongoing maintenance on Visa Card services requires additional time. We will update once services are fully restored.
Posted May 27, 2026 - 09:37 GMT-03:00
This incident affected: LATAM Payments processing partners (Colombia - Payment Processors).