First Bank Plc Nigeria maintenance

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Aug 22, 2026 - 22:05 GMT-03:00

Update

First Bank Plc Nigeria is under maintenance
Posted Aug 22, 2026 - 22:03 GMT-03:00

Update

We are continuing to investigate this issue.
Posted Aug 22, 2026 - 22:01 GMT-03:00

Investigating

We have identified some processing issues with First Bank Plc (Nigeria) in Nigeria. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Aug 22, 2026 - 21:51 GMT-03:00
This incident affected: EMEA Payment processing partners (Nigeria - Payment Processors).