Nedbank card acquiring down

Incident Report for Status dLocal

Resolved

This incident has been resolved
Posted Nov 28, 2025 - 09:42 GMT-03:00

Investigating

New incident: Investigating

We are currently experiencing an issue where with Nedbank card acquiring. Our team is investigating the issue with our partner and working to resolve it as soon as possible.
Posted Nov 28, 2025 - 09:40 GMT-03:00
This incident affected: EMEA Payment processing partners (South Africa - Payment Processors).