Mobicred ZA - Downtime

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 08:03 GMT-03:00

Update

It got recovered, keeping under monitoring
Posted Jun 04, 2026 - 07:41 GMT-03:00

Investigating

Mobicred is currently experiencing an issue and payments are failing. We are investigating to resolve it as soon as possible.
Posted Jun 04, 2026 - 03:44 GMT-03:00
This incident affected: EMEA Payment processing partners (South Africa - Payment Processors).