[Egypt] Issuer National Bank of Egypt and Mezza is expiriencing issues with card payment processing

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 00:13 GMT-03:00

Investigating

we have identified some processing issues with National Bank Egypt and Mezza.
Posted Mar 27, 2025 - 17:20 GMT-03:00
This incident affected: EMEA Payment processing partners (Egypt - Payment Processors).