We are continuing to investigate this issue, We will update the Bank feedback once available.
Posted Mar 19, 2026 - 23:18 GMT-03:00
Update
We are continuing to investigate this issue, We will update the Bank feedback once available.
Posted Mar 19, 2026 - 20:25 GMT-03:00
Update
We are still experiencing this issue, we will provide an update as soon as it becomes available from the bank.
Posted Mar 19, 2026 - 18:35 GMT-03:00
Update
We are still experiencing this issue, we will provide an update as soon as it becomes available from the bank.
Posted Mar 19, 2026 - 17:00 GMT-03:00
Update
We are still experiencing this issue. We will update the processors feedback once available
Posted Mar 19, 2026 - 14:52 GMT-03:00
Update
We are still experiencing this issue. We will update the processors feedback once available.
Posted Mar 19, 2026 - 12:35 GMT-03:00
Update
We are continuing to investigate this issue.
Posted Mar 19, 2026 - 08:58 GMT-03:00
Update
We are continuing to investigate this issue.
Posted Mar 19, 2026 - 07:42 GMT-03:00
Investigating
We have identified some processing issues with BBVA BANCOMER S.A. in MEXICO. We have contacted the processor and we will provide an update as soon as it becomes available.