FirstData Apparent incident with payment processing in Uruguay
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted May 31, 2021 - 00:14 GMT-03:00
Identified
The issue has been identified and a fix is being implemented.
Posted May 30, 2021 - 23:50 GMT-03:00
This incident affected: LATAM Payments processing partners (Payment processing in Uruguay).