[Payflex - Peach] Apparent incident with payment processing in South Africa

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 10:20 GMT-03:00

Update

We are continuing to investigate this issue.
Posted Mar 27, 2026 - 09:24 GMT-03:00

Update

We are continuing to investigate this issue.
Posted Mar 27, 2026 - 09:19 GMT-03:00

Investigating

Payflex is experiencing degraded performance on their Peach Integration.

We are currently investigating this incident and have raised it with Peach.

Date: March 27, 2026 at 10:46 AM

Components Affected: Checkout
Posted Mar 27, 2026 - 07:00 GMT-03:00
This incident affected: EMEA Payment processing partners (South Africa - Payment Processors).