[MFS] Apparent incident with payment processing in Kenya
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 01:24 GMT-03:00
Investigating
We have identified some processing issues with MFS in KENYA. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Sep 30, 2024 - 19:13 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Kenya).