[ZENITH Bank] Apparent incident with Card Issuer in Nigeria

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 00:49 GMT-03:00

Investigating

We have identified some processing issues with Zenith Bank in Nigeria. The Bank has been contacted by our Processor, and we will provide an update as soon as it becomes available.
Posted Jul 07, 2025 - 12:18 GMT-03:00
This incident affected: EMEA Payment processing partners (Nigeria - Payment Processors).