[Interswitch] Apparent incident with payment processing in Nigeria
Incident Report for Status dLocal
Resolved
This incident has been resolved, Interswitch Payments in Nigeria are operating correctly .
Posted Mar 19, 2023 - 02:54 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Mar 19, 2023 - 00:55 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Nigeria).