[Centric] Apparent incident with payment processing in Kenya
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Nov 19, 2022 - 04:55 GMT-03:00
Investigating
We have identified some processing issues with Centric in Kenya. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Nov 19, 2022 - 04:20 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Kenya).