[Egypt] Issuer National Bank of Egypt is expieriencing issues with card payment processing

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 14:04 GMT-03:00

Investigating

We have identified some processing issues with National Bank of Egypt
Posted Mar 25, 2025 - 12:42 GMT-03:00
This incident affected: EMEA Payment processing partners (Egypt - Payment Processors).