The processor is still working on the resolution. We will provide an update as soon as we receive any further information from them.
Posted Jun 06, 2026 - 07:39 GMT-03:00
Update
We are seeing improvement in transaction processing; however, intermittent failures are still occurring. We continue to monitor the situation closely and are working with the affected provider to confirm full service recovery
Posted Jun 06, 2026 - 05:25 GMT-03:00
Update
The issue is still ongoing and remains under investigation with the processor. We will provide the next update as soon as more information becomes available.
Posted Jun 06, 2026 - 01:28 GMT-03:00
Update
The issue is still under investigation with the processor, and we will communicate any relevant updates as they become available.
Posted Jun 05, 2026 - 22:33 GMT-03:00
Investigating
We have identified some processing issues with Interswitch in Nigeria. We have contacted the processor and we will provide an update as soon as it becomes available.