[Peach Payments] Apparent incident with payment processing in South Africa.
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Sep 30, 2024 - 04:15 GMT-03:00
Investigating
We have identified some processing issues with Peach Payments in South Africa. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Sep 29, 2024 - 21:48 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (South Africa - Payment Processors).