MFS/Beyonic Apparent incident with payment processing in Kenya
Incident Report for Status dLocal
Resolved
This has been resolved and we are monitoring
Posted May 28, 2021 - 06:52 GMT-03:00
Identified
Kindly note that we are currently experiencing a temporary interference with services on the Beyonic (MFS) platform.

Our technical team is working to resolve this as soon as possible.

Transaction processing might be degraded
Posted May 28, 2021 - 06:16 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processing in Kenya).