[Cellulant] Apparent incident with payment processing in Kenya
Incident Report for Status dLocal
Resolved
This incident has been resolved,
Kenya Payments in CELLULANT are operating correctly.
Posted May 30, 2024 - 10:54 GMT-03:00
Investigating
We have identified some processing issues with CELLULANT in KENYA. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted May 30, 2024 - 08:29 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Kenya).