[Simpaisa] Apparent incident with payment processing in Pakistan

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 05:54 GMT-03:00

Investigating

We have identified some processing issues with Simpaisa in Pakistan. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Mar 18, 2025 - 05:47 GMT-03:00
This incident affected: APAC Payment processing partners (Pakistan - Payment Processors).