[Evo Payments] Apparent incident with payment processing in Mexico
Incident Report for Status dLocal
Resolved
This incident has been resolved, Evo Payments Payments in MEXICO are operating correctly .
Posted Jan 25, 2023 - 04:02 GMT-03:00
Investigating
We have identified some processing issues with Evo Payments in MEXICO. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Jan 25, 2023 - 03:34 GMT-03:00
This incident affected: LATAM Payments processing partners (Payment processors in Mexico).