[BAC Credomatic International ] Apparent incident with payment processing in Guatemala
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Nov 11, 2024 - 11:11 GMT-03:00
Investigating
We have identified some processing issues with BAC CREDOMATIC INTERNATIONAL in GUATEMALA. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Nov 11, 2024 - 07:35 GMT-03:00
This incident affected: CA Payments processing partners (Guatemala - Payment Processors).