[MFS] Apparent incident with payment processing in Kenya

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 20:52 GMT-03:00

Investigating

We have identified some processing issues with MFS in KENYA. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Mar 20, 2025 - 17:39 GMT-03:00
This incident affected: EMEA Payment processing partners (Kenya - Payment Processors).