BANQUE MISR incident with payment processing in Egypt

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 05:37 GMT-03:00

Investigating

We are currently investigating this issue.
Posted Apr 18, 2025 - 04:44 GMT-03:00
This incident affected: EMEA Payment processing partners (Egypt - Payment Processors).