[Banco Multiple BHD S.A] Apparent incident with payment processing in Dominican Republica

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 09:18 GMT-03:00

Investigating

We are currently investigating this issue.
Posted Feb 18, 2026 - 09:08 GMT-03:00
This incident affected: CA Payments processing partners (Dominican Republic - Payment Processors).