Cellulant apparent incident with payment processing in Kenya
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 05:59 GMT-03:00
Investigating
We are currently investigating this issue.
Posted May 31, 2023 - 11:40 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Kenya).