[Budpay] Apparent incident with payment processing in Nigeria

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 06:45 GMT-03:00

Investigating

We have identified some processing issues with BUDPAY in NIGERIA. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Mar 27, 2025 - 05:09 GMT-03:00
This incident affected: EMEA Payment processing partners (Nigeria - Payment Processors).