[Simpaisa] Apparent incident with payment processing in Pakistan for Jazzcash payment method
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Nov 22, 2024 - 16:14 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Nov 22, 2024 - 09:38 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Pakistan - Payment Processors).