Nigeria- Interswitch, Fidelity Bank incidente (2024-09-26)
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 10:12 GMT-03:00
Investigating
We have identified some processing issues with Fidelity Bank in Nigeria. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Sep 26, 2024 - 06:16 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Nigeria - Payment Processors).