[EVO] Apparent incident with payment processing in Mexico
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 20:06 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Mar 23, 2023 - 19:07 GMT-03:00
This incident affected: LATAM Payments processing partners (Payment processors in Mexico).