[Simpaisa] Apparent incident with payment processing in Pakistan for Easypaisa payment method

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 01:03 GMT-03:00

Investigating

We have identified some processing issues with Easypaisa payment method in Pakistan. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Mar 21, 2025 - 00:14 GMT-03:00
This incident affected: APAC Payment processing partners (Pakistan - Payment Processors).