Flutterwave Apparent incident with payment
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Jun 11, 2021 - 08:56 GMT-03:00
Identified
Customers are unable to make payments due to transaction failures at this time.

The issue has been identified and resolution is ongoing to fix it as soon as possible.

We're sorry about the inconvenience this may cause.
Posted Jun 11, 2021 - 08:35 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Nigeria).