[Peach Payments] Apparent incident with payment processing in South Africa.

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Jun 04, 2024 - 10:05 GMT-03:00

Update

We are continuing to investigate this issue.
Posted Jun 04, 2024 - 01:36 GMT-03:00

Investigating

We have identified some processing issues with Peach Payments in South Africa. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Jun 04, 2024 - 01:24 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (South Africa - Payment Processors).