BAC Credomatic - Guatemala Latency Spike

Incident Report for Status dLocal

Resolved

The issuer had uploaded an update in their system that caused this latency. It has been resolved now.
Posted Jan 19, 2026 - 16:26 GMT-03:00

Monitoring

The issue is ongoing and only with transactions of cards issued by Banco G&T Continental. This is an issuer problem - already investigating to check how to stabilize.
Posted Jan 19, 2026 - 11:41 GMT-03:00

Investigating

We are currently seeing latency spikes in acquirer - being investigated by partner
Posted Jan 19, 2026 - 10:43 GMT-03:00
This incident affected: CA Payments processing partners (Guatemala - Payment Processors).