Safexpay Apparent incident with payment processing in India
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 18:01 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Sep 13, 2021 - 17:29 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in India).