[Interswitch] Apparent incident with payment processing in Nigeria

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 22:14 GMT-03:00

Update

The processor has been working on have their services fully restored. Sorry for the inconvenience caused. We will keep you posted
Posted Jun 22, 2026 - 20:26 GMT-03:00

Update

We are still investigating the issue with the processor. We will provide more updates as soon as we have them
Posted Jun 22, 2026 - 17:36 GMT-03:00

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 12:49 GMT-03:00

Update

We are checking the incident with the processor. We will let you know as soon as we have more updates
Posted Jun 22, 2026 - 10:02 GMT-03:00

Investigating

We have identified some processing issues with Interswitch in Nigeria. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Jun 22, 2026 - 07:43 GMT-03:00
This incident affected: EMEA Payment processing partners (Nigeria - Payment Processors).