[Evo] Apparent incident with payment processing in Mexico
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 18:33 GMT-03:00
Investigating
We are currently investigating this issue
Posted Jan 17, 2023 - 17:15 GMT-03:00