[Nigeria] Apparent incident with payment processing delays in Nigeria Banks

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted May 16, 2026 - 09:19 GMT-03:00

Update

We are continuing to investigate this issue.
Posted May 16, 2026 - 08:20 GMT-03:00

Investigating

We have identified high latency issues with several issuers in Nigeria. The processor has been contacted and is currently investigating the issue. We will provide further updates as soon as more information becomes available.
Posted May 16, 2026 - 04:05 GMT-03:00
This incident affected: EMEA Payment processing partners (Nigeria - Payment Processors).