Absa scheduled maintenance

Scheduled for Apr 19, 19:30 - 20:30 GMT-03:00

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 13, 2026 - 08:59 GMT-03:00

Scheduled

ABSA will be undergoing scheduled maintenance During this time, ABSA services may experience degraded performance.

Stitch's core platform remains fully operational.

Affected Components:

Card

Card Issuer - ABSA
Under maintenance

Pay By Bank

ABSA
Under maintenance

Pay By Bank

ABSA Pay
Under maintenance
Posted Apr 13, 2026 - 08:59 GMT-03:00
This scheduled maintenance affects: EMEA Payment processing partners (South Africa - Payment Processors).