Peach Payments Degraded Performance
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 08:54 GMT-03:00
Investigating
We are currently experiencing connectivity issues that are causing service disruption to some of our customers
Our Technical Teams are engaged and are working on priority to resolve this issue.
Posted Jul 19, 2024 - 04:28 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in South Africa).