Peach Payments Apparent incident with payment processing in South Africa
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Sep 18, 2021 - 09:28 GMT-03:00
Identified
We have identified an issue causing some traffic to be dropped. This is being worked on.
Posted Sep 18, 2021 - 07:50 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in South Africa).