Capitec Pay – Service Disruption

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 14:49 GMT-03:00

Investigating

We are currently investigating an issue affecting Capitec Pay transactions. Our team has identified the issue and has engaged Capitec Pay to investigate and work towards a resolution.

We apologise for any inconvenience this may cause and will continue to provide updates on this status page as more information becomes available.
Posted Jul 14, 2026 - 11:20 GMT-03:00
This incident affected: EMEA Payment processing partners (South Africa - Payment Processors).