Interswitch apparent incident with processing in Nigeria
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted May 21, 2023 - 07:51 GMT-03:00
Identified
The issue has been identified and a fix is being implemented.
Posted May 21, 2023 - 06:20 GMT-03:00
This incident affected: APAC & EMEA Payment processing partners (Payment processors in Nigeria).