ACCESS BANK PLC incident with payment processing in Nigeria

Incident Report for Status dLocal

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 11:33 GMT-03:00

Investigating

We are currently investigating this issue.
Posted Apr 02, 2025 - 10:28 GMT-03:00
This incident affected: EMEA Payment processing partners (Nigeria - Payment Processors).