[BANCO MULTIPLE BHD, S. A.] Apparent incident with payment processing in Domincian Republic.
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Oct 23, 2024 - 03:43 GMT-03:00
Investigating
We have identified some processing issues with BANCO MULTIPLE BHD, S. A. in DOMINCIAN REPUBLIC. We have contacted the processor and we will provide an update as soon as it becomes available.
Posted Oct 22, 2024 - 22:50 GMT-03:00
This incident affected: CA Payments processing partners (Dominican Republic - Payment Processors).