FirstData Apparent incident with payment processing in Uruguay
Incident Report for Status dLocal
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 13:01 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Jun 08, 2021 - 11:44 GMT-03:00
This incident affected: LATAM Payments processing partners (Payment processing in Uruguay).